Sponsored

No power to trailer backup light

scubasmac

New member
First Name
Stephen
Joined
Sep 19, 2022
Threads
1
Messages
2
Reaction score
0
Location
NC
Vehicles
2022 F150 4x4 STX 2.7EB
Hi just recently purchased a 2022 STX. There is no voltage on the center pin of the 7 pin harness. I need it for the surge brake bypass solenoid on my boat trailer. I’ve looked but haven’t found much. I have checked fuse #58 in the fuse box under the hood.
Thanks for any help!
Sponsored

 

Buyer2021

Well-known member
Joined
Feb 9, 2021
Threads
24
Messages
1,650
Reaction score
2,849
Location
TX
Vehicles
2022 Lariat SuperCab and 2005 XLT SuperCab
Occupation
retired!
Have you tested with an incandescent lamp load present (e.g. rig a temporary / fake backup light using the ground-pin on the 7-pin connector; not some other 'handy' chassis ground on the truck)?

If not, try that and if the lamp lights then try running the solenoid tigger in parallel with the lamp and see if that works to deactivate the surge brakes when in reverse. Parallel so the lamp has a complete circuit without going through the solenoid.

(long shot - thinking maybe the too-smart Smart Connector wants to 'see' a lamp load / complete backup-lamp circuit through the 7-pin connector before powering that pin?)
 
Last edited:
OP
OP

scubasmac

New member
First Name
Stephen
Joined
Sep 19, 2022
Threads
1
Messages
2
Reaction score
0
Location
NC
Vehicles
2022 F150 4x4 STX 2.7EB
I can try that to see what happens. Thanks

Has anyone ran into this issue before?
 

SouthernGuy

Active member
First Name
Sam
Joined
Dec 17, 2021
Threads
2
Messages
40
Reaction score
51
Location
Alabama
Vehicles
'21 Lariat Powerboost, 7.2K PPoB
Occupation
Retired
I had a similar problem with the trailer running lights not working. Its controlled by Fuse #55, which turned out to be a bad fuse (visually looked OK, but a flaky connection). Replaced the fuse and all is good now.
 

LD50

Well-known member
Joined
Jan 7, 2022
Threads
2
Messages
96
Reaction score
85
Location
IL
Vehicles
2019 Raptor, 2022 Lariat on order
Have you actually tried to hook the trailer up to it to see if it works? I believe it's been covered in other threads that power is not supplied to some or all of the functions in the plug unless it detects that a harness has been plugged in.
 

Sponsored

DK4

Well-known member
Joined
Jan 23, 2022
Threads
4
Messages
320
Reaction score
363
Location
USA
Vehicles
Truck
Bumping this older thread. I’m having the same problem. Just picked up a new trailer that has reverse lights but they don’t get power when my truck is in reverse. Also don't light up when doing the trailer light test.

Checked the trailer separately with a trailer light test battery box at the trailer dealer and they work fine then.

I checked the center pin with a halogen light tester and no juice, reverse or not. Other pins like running lights are good.

Checked fuse 58 under the hood and it’s there and I get power to both sides of it both when the truck is in reverse or not.

Looking at the back of my 7-pin connector on my truck and there is a gray wire with black stripe going to the center pin.

My truck is a 502A with max tow. It doesn’t have the connector that has the TPMS and camera however.

Any ideas? Thanks guys.
 

DK4

Well-known member
Joined
Jan 23, 2022
Threads
4
Messages
320
Reaction score
363
Location
USA
Vehicles
Truck
Hey guys, I got my reverse lights to work. I have no idea exactly what I did to get them working, but here are the things I did in case anyone else reads this with the same problem.

Setup my new trailer in the APIM (I had selected my previous trailer before, so I did have a trailer selected previously when they didn’t work).

Cleaned the trailer side connector and put a little dialectic grease in it. It was a little wet.

Pulled the 10 amp micro fuse in the #58 position under the hood and cleaned the tiny spade connector legs.

Installed fuse back in and tested power to both sides (all good). Did not test it prior unfortunately.

After all that I had power to my center pin which I did not have before the above.

My opinion is pulling the fuse and reinstalling it probably is what did the trick but who knows.

Pretty stoked :giggle:

Ford F-150 No power to trailer backup light IMG_2257
Sponsored

 
 




Top